TruSat Help Desk

Sorry - I know now you must type in code, no pasting allowed.

Will this work for general public?

1 Like

Yes,
The bot seems to have mis-read my posts as advertising. I am a rookie and a novice at this, and tried to respond to the bot as the automated message advised. Please unlock my post and allow me to continue to learn. I want to be involved and supportive. Thanks, and have a great day (and night…)
Lucky O’

1 Like

Hi lucky o,

Glad to have someone else to join us observing. What equipment do you use, binoculars, camera, stopwatch,?

Do you have a way to get predictions for things to look at?

What questions do you have to get started the next clear night?

1 Like

@hafsnt Hey Brad,

Apologies for the delay. This seems like an unusual issue that I haven’t come across when testing! Couple of questions…

  1. Can you confirm for me that the issue is that you cannot paste your “secret” into the login form?
  2. What browser you are using?
  3. Were you eventually able to log in or still having problems?

thanks,
John.

1 Like
  1. Can you confirm for me that the issue is that you cannot paste your “secret” into the login form?
    Correct

  2. What browser you are using?
    Google Chrome Version 78.0.3904.108 (Official Build) (64-bit)

  3. Were you eventually able to log in or still having problems?
    Yes, I just had to manually type in the code (that takes a minute…) I am still logged in, but next time the session times out, I’ll check to be sure you have to type it.

1 Like

Thanks for the replies! I have the same version of Chrome and I cannot replicate the bug. Please do let me know if it happens again and I will dig further into it!

1 Like

I tried to add a new station to show someone how to use TruSat and it locked up on a blank screen.

1 Like

@hafsnt Do you know if this is repeatable or what browser you were using?

Yes it happened on both chrome and Firefox

@hafsnt We’re having trouble reproducing the error. There’s a chance this blank screen was due to a connection issue. When you get a chance, would you mind trying to add a station again and confirming that it’s not showing up on your settings page after hitting submit?

Could it be b/c I already have 10 set up?

1 Like

THAT I was able to reproduce! I got a blank screen after trying to submit an 11th station.

Bug filed here: https://github.com/TruSat/trusat-frontend/issues/294

Thanks for catching, @hafsnt

@hafsnt Hey Brad,

We actually had a cap on the number of stations allowed per user at 10 since launch! We just lifted the cap. You should be all good to add your 11th station now. Cheers to @Kenan.ONeal for the quick fix.

John.

Hello,

Has MetaMask login link been turned off? Can’t log in to supply observations.

@hafsnt mm, that’s not functioning right. Are you saying that when you’re on https://trusat.org/login you can see the normal login form (email, password, secret) but not the “Log in with Metamask” button?

Any other details you can give to help us pinpoint what’s happening?

Thanks,
Mike

I don’t think i should upload screen shot of login screen. Logged into MetaMask as always, but when I push the button to log in with it, a new dialog I’ve never seen before pops up:

Says if you are using Brave Browser (which I’m not)…yadda yadda.

The “Log in with Metamask” button is there, but doesn’t work as before

Hey @hafsnt

The message that popped up was the following:

Please sign in to MetaMask plugin and try again!

If you are using Brave Browser you may have to check permissions on your MetaMask plugin by navigating to the Settings tab via your avatar icon and then clicking Connections. From there click the connect button to grant TruSat.org access!`

This message (written by me) is shown to users when TruSat cannot read your etherem address (your unique identifier) from the MetaMask plugin. This usually happens because you are not logged in to MetaMask, or it can happen when your Brave browser settings require another step to ensure that you trust the website that is seeking access to your MetaMask.

Can you check that your MetaMask plugin looks something like this?:

If it does, then you are logged in to the plugin. But if your MetaMask plugin looks like this then you are logged out:

If it is the case that are logged in, and are having the same problem, try following the steps in the prompt. Don’t worry, there is nothing to worry about with respect to security - this is just another layer of security that Brave is asking for (a good thing!)

John.

p.s. I am really happy you are using MetaMask, welcome to Web3 :slight_smile:

Aha! You have to log into MetaMask before opening TruSat! Has it always been that way? B/c the only reason I ever log into MM is to log in to TruSat, and only opening TS would remind me I’m not logged in…

I find that MetaMask periodically signs me out, presumably for security reasons, in which case I have to sign into MetaMask to be able to sign into TruSat.

Yeah - periodic sign out should be expected from MetaMask. @hafsnt